Is my smartphone compatible?

Your Pulse uses your smartphone to sync your daily steps to the mobile app. To sync your steps, you need to ‘pair’ the Pulse to your smartphone and upload your daily activity.

In Sync mode, the Pulse is compatible with the most popular Android or iOS smartphones, such as:

  • Apple iPhone (iOS 8 + operating system) 4s, 5, 5c, 5s, 6, 6 plus,  6s, 6s plus, 7, 7 plus 
  • Android (4.0.3 or later operating system and must support Bluetooth 4.3)  
  • HTC Butterfly 2, S, Desire (510,516, 601, 610, 616, 816, 820, eye) One Series
  • Huawei Ascend P7
  • LG Optimus Exceed 2, Fuel, L35, L40, L65, L70, L80, L90, G, GPro, F60, F70, Realm, Tribute, Volt, VU 3.0, G Series.
  • Google Nexus 4, Nexus 5, Nexus 6
  • OnePlus One OnePlus X
  • Samsung Galaxy S2 Samsung Galaxy S4 Samsung Galaxy S4 mini* Samsung Galaxy S5 Samsung Galaxy S6 Samsung Galaxy S7 Samsung Galaxy Note 2 Samsung Galaxy

*Windows phone isn’t compatible with the app or Pulse.

*Some operating systems may need to be updated to the latest versions.

Pairing and syncing your Pulse

 

Have more questions? Submit a request
Powered by Zendesk